Australian Premium Phone Support experiencing issues
Incident Report for Cin7
Resolved
This issue has now been resolved. Our Australian Premium Phone Support number can now be used.
Posted 11 months ago. Oct 25, 2018 - 16:32 NZDT
Investigating
We are currently investigating issues dialing our Australian Premium Phone Support number. The team will be regularly monitoring the help site emails for any urgent requests till this is resolved.
Posted 11 months ago. Oct 25, 2018 - 15:39 NZDT