Cin7 Performance Degradation on login page
Incident Report for Cin7 Omni
Resolved
This incident has been resolved.
Posted Apr 19, 2018 - 19:44 NZST
Investigating
The Cin7 Technology Team are working to isolate a performance degradation issue on the login page. End users are able to access all functionality. If you are experiencing slow login times, please contact support: https://help.cin7.com/contact/

- Cin7 Technology Team
Posted Apr 19, 2018 - 16:12 NZST