Cin7 Status Page - Cin7 Core: Cin7 Pay Errors impacting some customers – Incident details

Core: 3rd Party Integrations experiencing degraded performance

Cin7 Core: Cin7 Pay Errors impacting some customers

Monitoring
Degraded performance
Started about 4 hours ago

Affected

Cin7 Core

Degraded performance from 8:47 PM to 11:25 PM, Operational from 11:25 PM to 12:00 AM

Core: 3rd Party Integrations

Degraded performance from 8:47 PM to 11:25 PM, Operational from 11:25 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We are continuing to work on a fix for this incident with our payment partner Stripe.

    This incident is also impacting new sign-ups and payments from document templates.

  • Investigating
    Investigating

    Some Cin7 Pay merchants using Core may experience errors when accessing embedded payment components or processing payments directly within the Sales module. Payments initiated through document templates (quotes, orders, invoices) and the B2B Portal continue to process normally. We have escalated the issue to Stripe, who is actively working on a resolution. We will provide updates as they become available.