Phone system maintenance
Incident Report for Cin7 Omni
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 14:09 NZST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 08, 2020 - 12:02 NZST
Investigating
We are undergoing phone system maintenance between 12 noon and 2pm NZT today Monday 8th June. To contact us during this time please use the form on https://help.cin7.com/contact-support/ and create a ticket/case
Posted Jun 08, 2020 - 12:01 NZST