System Slowness
Incident Report for Cin7
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 15:01 NZST
Investigating
Currently, some customers are experiencing system slowness issues at times. We're aware of system slowness in certain situations and are investigating the root cause.
Apologies if this issue is affecting you, The system remains usable at this time. We'll provide an update as soon as we have one.
Posted Jun 23, 2020 - 16:36 NZST