System Updates
Incident Report for Cin7 Omni
Resolved
The system updates have been completed.
Posted Nov 23, 2020 - 00:06 NZDT
Monitoring
We are currently performing system updates. Please be aware you might experience slowness or intermitting outages while we perform this operation. Thank you.
Posted Nov 22, 2020 - 22:38 NZDT