Reports Module is currently unavailable
Incident Report for Cin7 Omni
Resolved
This incident has been resolved.
Posted Nov 21, 2020 - 18:09 NZDT
Update
Please be aware that momentarily you will be experiencing intermittent outages while we apply the appropiate fixes.
Posted Nov 21, 2020 - 16:45 NZDT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 21, 2020 - 15:49 NZDT