Phone system outage
Incident Report for Cin7 Omni
Resolved
This incident has been resolved.
Posted Dec 27, 2019 - 11:18 NZDT
Monitoring
The phone system issues have been resolved. We will continue to monitor.
Posted Dec 27, 2019 - 10:10 NZDT
Investigating
Cin7 is currently experiencing issues with our phone system, and we are not currently able to take calls. We apologise for the inconvenience - if you need to get in touch, please submit a ticket at https://help.cin7.com/contact-support/ and a technical specialist will get back to you ASAP.
Posted Dec 27, 2019 - 09:50 NZDT